it-swarm.cn

WordPress 3.0.1自动更新问题

我的WordPress现在是2.7版。我想使用自动更新功能将其升级到3.0.1。我正在使用FTPS连接类型。

升级应该是直接的,但是,我一直遇到这个错误:

安装失败从 http://wordpress.org/wordpress-3.0.1.Zip 下载更新...

打开更新包......

验证解压缩的文件...

安装最新版本......

无法复制文件:/wp-admin/css/theme-editor.dev.css

安装失败

我已经检查了/wp-admin/css文件夹的权限,它被设置为777。

问题是什么?我搜索了互联网,但似乎 很多人有同​​样的问题

有任何想法吗?

2
Graviton

自动更新并不总是有效,它几乎总是有效。我只是手动升级而不用担心。我有几次自动更新失败,它会在下一次出现新版本时成功(在我在破损期间手动更新之后)。

2
curtismchale

有一个针对WordPress的补丁(http://core.trac.wordpress.org/ticket/10913)应该进入3.2并帮助解决大多数人遇到它的升级错误。服务器运行Pure-FTPd似乎只会发生这种情况。在此期间,有一个插件可以帮助修复大多数人的更新: http://wordpress.org/extend/plugins/ftp-upgrade-fix/

2
user3757

检查您可能设置的文件的所有者777,但如果ftp服务不在所有者组或所有者,这可能是您的问题

您需要远程登录到Web服务器以检查/修复此问题ls -l以查看设置chown是您如何更改它

0
Pbearne

我尝试了所有在wordpress.org/support/topic/upgrade-gone-worng-pls-help中提到的自动升级,但无济于事。

相反,我按照codex.wordpress.org/Upgrading_WordPress上的说明或多或少地进行了手动升级。我没有使用FTP,而是使用我的托管服务提供商CPanel - 然后我写了我采取的步骤,以便其他人可能受益 - 请参阅 http://misterjaytee.com/2010/09/11/errors -updating - WordPress的

希望下一次自动升级能够正常运行,但如果没有,我现在有信心手动升级。

0
misterjaytee
0
Nabeel

检查引用文件的权限。在这种情况下:/wp-admin/css/theme-editor.dev.css

0
artlung